What’s Vulnerable › Vulnerabilities
CVE-2023-5002: Pgadmin4: remote code execution by an authenticated user
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-22 · updated 2026-06-17
- Weakness: CWE-78
Description
A flaw was found in pgAdmin. This issue occurs when the pgAdmin server HTTP API validates the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. Versions of pgAdmin prior to 7.6 failed to properly control the server code executed on this API, allowing an authenticated user to run arbitrary commands on the server.
Affected products
- Fedoraproject Fedora: 37, 38
- pgadmin.org pgAdmin 4: before 7.7 — fixed in 7.7
How to fix
Upgrade to a fixed version: pgadmin.org pgAdmin 4 7.7. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2239164
- https://github.com/pgadmin-org/pgadmin4/issues/6763
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2S24D3S2GVNGTDNE6SF2OQSOPU3H72UW/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VIRTMQZEE6K7RD37ERZ2UFYFLEUXLQU3/
- https://bugzilla.redhat.com/show_bug.cgi?id=2239164
- https://github.com/pgadmin-org/pgadmin4/issues/6763
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/2S24D3S2GVNGTDNE6SF2OQSOPU3H72UW/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VIRTMQZEE6K7RD37ERZ2UFYFLEUXLQU3/
Get alerted when CVE-2023-5002 or the next vulnerability affects your stack