What’s Vulnerable › Vulnerabilities
CVE-2023-5005: Autocomplete Location field Contact Form 7 < 3.0 - Admin+ Store Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Autocomplete Location field Contact Form 7 WordPress plugin before 3.0, autocomplete-location-field-contact-form-7-pro WordPress plugin before 2.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Codesmade Autocomplete Location Field Contact Form 7: before 3.0; before 2.0 — fixed in 2.0, 3.0
How to fix
Upgrade to a fixed version: Codesmade Autocomplete Location Field Contact Form 7 2.0, 3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/bfb174d4-7658-4883-a682-d06bda89ec44
- https://wpscan.com/vulnerability/bfb174d4-7658-4883-a682-d06bda89ec44
Get alerted when CVE-2023-5005 or the next vulnerability affects your stack