What’s Vulnerable › Vulnerabilities

CVE-2023-5009: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 13.12 before 16.2.7, all versions starting from 16.3 before 16.3.4. It was possible for an attacker to run pipeline jobs as an arbitrary user via scheduled security scan policies. This was a bypass of [CVE-2023-3932](https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-3932) showing additional impact.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.2.7, 16.3.4; GitLab 16.2.7, 16.3.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-5009 or the next vulnerability affects your stack