What’s Vulnerable › Vulnerabilities
CVE-2023-50164: Apache Struts: File upload component had a directory traversal vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 80.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-07 · updated 2026-06-17
- Weakness: CWE-552
Description
An attacker can manipulate file upload params to enable paths traversal and under some circumstances this can lead to uploading a malicious file which can be used to perform Remote Code Execution. Users are recommended to upgrade to versions Struts 2.5.33 or Struts 6.3.0.2 or greater to fix this issue.
Affected products
- Apache Struts: from 2.0.0 before 2.5.33; from 6.0.0 before 6.3.0.2 — fixed in 2.5.33, 6.3.0.2
How to fix
Upgrade to a fixed version: Apache Struts 2.5.33, 6.3.0.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/176157/Struts-S2-066-File-Upload-Remote-Code-Execution.html
- https://lists.apache.org/thread/yh09b3fkf6vz5d6jdgrlvmg60lfwtqhj
- https://security.netapp.com/advisory/ntap-20231214-0010/
- https://www.openwall.com/lists/oss-security/2023/12/07/1
- http://packetstormsecurity.com/files/176157/Struts-S2-066-File-Upload-Remote-Code-Execution.html
- https://lists.apache.org/thread/yh09b3fkf6vz5d6jdgrlvmg60lfwtqhj
- https://security.netapp.com/advisory/ntap-20231214-0010/
- https://www.openwall.com/lists/oss-security/2023/12/07/1
Get alerted when CVE-2023-50164 or the next vulnerability affects your stack