What’s Vulnerable › Vulnerabilities
CVE-2023-50179
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-09 · updated 2026-06-17
- Weakness: CWE-295
Description
An improper certificate validation vulnerability [CWE-295] in FortiADC 7.4.0, 7.2 all versions, 7.1 all versions, 7.0 all versions may allow a remote and unauthenticated attacker to perform a Man-in-the-Middle attack on the communication channel between the device and public SDN connectors.
Affected products
- Fortinet FortiADC: from 7.0.0 before 7.4.1 — fixed in 7.4.1
How to fix
Upgrade to a fixed version: Fortinet FortiADC 7.4.1. Check the vendor advisory for mitigations.
References
- https://fortiguard.fortinet.com/psirt/FG-IR-23-480
- https://fortiguard.fortinet.com/psirt/FG-IR-23-480
Get alerted when CVE-2023-50179 or the next vulnerability affects your stack