What’s Vulnerable › Vulnerabilities
CVE-2023-50214: D-Link G416 nodered tar File Handling Command Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-78
Description
D-Link G416 nodered tar File Handling Command Injection Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of D-Link G416 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the HTTP service listening on TCP port 80. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-21808.
Affected products
- D-Link G416: before 1.09b01 — fixed in 1.09b01
How to fix
Upgrade to a fixed version: D-Link G416 1.09b01. Check the vendor advisory for mitigations.
References
- https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10367
- https://www.zerodayinitiative.com/advisories/ZDI-23-1830/
- https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10367
- https://www.zerodayinitiative.com/advisories/ZDI-23-1830/
Get alerted when CVE-2023-50214 or the next vulnerability affects your stack