What’s Vulnerable › Vulnerabilities
CVE-2023-50228: Parallels Desktop Updater Improper Verification of Cryptographic Signature Local Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-347
Description
Parallels Desktop Updater Improper Verification of Cryptographic Signature Local Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of Parallels Desktop. An attacker must first obtain the ability to execute low-privileged code on the target host system in order to exploit this vulnerability. The specific flaw exists within the Updater service. The issue results from the lack of proper verification of a cryptographic signature. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of root. . Was ZDI-CAN-21817.
Affected products
- Parallels Desktop: before 19.1.0_\(54729\) — fixed in 19.1.0_\(54729\)
How to fix
Upgrade to a fixed version: Parallels Desktop 19.1.0_\(54729\). Check the vendor advisory for mitigations.
References
- https://kb.parallels.com/en/125013
- https://www.zerodayinitiative.com/advisories/ZDI-23-1803/
- https://kb.parallels.com/en/125013
- https://www.zerodayinitiative.com/advisories/ZDI-23-1803/
Get alerted when CVE-2023-50228 or the next vulnerability affects your stack