What’s Vulnerable › Vulnerabilities
CVE-2023-50231: NETGEAR ProSAFE Network Management System saveNodeLabel Cross-Site Scripting Privilege Escalation Vulnerability
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 53.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-79
Description
NETGEAR ProSAFE Network Management System saveNodeLabel Cross-Site Scripting Privilege Escalation Vulnerability. This vulnerability allows remote attackers to escalate privileges on affected installations of NETGEAR ProSAFE Network Management System. Minimal user interaction is required to exploit this vulnerability. The specific flaw exists within the saveNodeLabel method. The issue results from the lack of proper validation of user-supplied data, which can lead to the injection of an arbitrary script. An attacker can leverage this vulnerability to escalate privileges to resources normally protected from the user. Was ZDI-CAN-21838.
Affected products
- NETGEAR ProSAFE Network Management System: before 1.7.0.31 — fixed in 1.7.0.31
How to fix
Upgrade to a fixed version: NETGEAR ProSAFE Network Management System 1.7.0.31. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065901/Security-Advisory-for-Stored-Cross-Site-Scripting-on-the-NMS300-PSV-2023-0106
- https://www.zerodayinitiative.com/advisories/ZDI-23-1847/
- https://kb.netgear.com/000065901/Security-Advisory-for-Stored-Cross-Site-Scripting-on-the-NMS300-PSV-2023-0106
- https://www.zerodayinitiative.com/advisories/ZDI-23-1847/
Get alerted when CVE-2023-50231 or the next vulnerability affects your stack