What’s Vulnerable › Vulnerabilities
CVE-2023-50232: Inductive Automation Ignition getParams Argument Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-88
Description
Inductive Automation Ignition getParams Argument Injection Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Inductive Automation Ignition. User interaction is required to exploit this vulnerability in that the target must connect to a malicious server. The specific flaw exists within the getParams method. The issue results from the lack of proper validation of a user-supplied string before using it to prepare an argument for a system call. An attacker can leverage this vulnerability to execute code in the context of the current user. Was ZDI-CAN-22028.
Affected products
- Inductive Automation Ignition: from 8.1.0 before 8.1.33 — fixed in 8.1.33
How to fix
Upgrade to a fixed version: Inductive Automation Ignition 8.1.33. Check the vendor advisory for mitigations.
References
- https://security.inductiveautomation.com/?tcuUid=fc4c4515-046d-4365-b688-693337449c5b
- https://www.zerodayinitiative.com/advisories/ZDI-24-184/
- https://security.inductiveautomation.com/?tcuUid=fc4c4515-046d-4365-b688-693337449c5b
- https://www.zerodayinitiative.com/advisories/ZDI-24-184/
Get alerted when CVE-2023-50232 or the next vulnerability affects your stack