What’s Vulnerable › Vulnerabilities
CVE-2023-50245: OpenEXR-viewer memory overflow vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-11 · updated 2026-06-17
- Weakness: CWE-120
Description
OpenEXR-viewer is a viewer for OpenEXR files with detailed metadata probing. Versions prior to 0.6.1 have a memory overflow vulnerability. This issue is fixed in version 0.6.1.
Affected products
- afichet openexr-viewer: before 0.6.1 — fixed in 0.6.1
How to fix
Upgrade to a fixed version: afichet openexr-viewer 0.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/afichet/openexr-viewer/commit/d0a7e85dfeb519951fb8a8d70f73f30d41cdd3d9
- https://github.com/afichet/openexr-viewer/security/advisories/GHSA-99jg-r3f4-rpxj
- https://github.com/afichet/openexr-viewer/commit/d0a7e85dfeb519951fb8a8d70f73f30d41cdd3d9
- https://github.com/afichet/openexr-viewer/security/advisories/GHSA-99jg-r3f4-rpxj
Get alerted when CVE-2023-50245 or the next vulnerability affects your stack