What’s Vulnerable › Vulnerabilities
CVE-2023-50254: Deepin Reader RCE vulnerability due to a design flaw
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-22 · updated 2026-06-17
- Weakness: CWE-22
Description
Deepin Linux's default document reader `deepin-reader` software suffers from a serious vulnerability in versions prior to 6.0.7 due to a design flaw that leads to remote command execution via crafted docx document. This is a file overwrite vulnerability. Remote code execution (RCE) can be achieved by overwriting files like .bash_rc, .bash_login, etc. RCE will be triggered when the user opens the terminal. Version 6.0.7 contains a patch for the issue.
Affected products
- Deepin Reader: before 6.0.7 — fixed in 6.0.7
How to fix
Upgrade to a fixed version: Deepin Reader 6.0.7. Check the vendor advisory for mitigations.
References
- https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04
- https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6
- https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495
- https://github.com/linuxdeepin/deepin-reader/commit/4db7a079fb7bd77257b1b9208a7ab26aade8fe04
- https://github.com/linuxdeepin/deepin-reader/commit/c192fd20a2fe4003e0581c3164489a89e06420c6
- https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-q9jr-726g-9495
Get alerted when CVE-2023-50254 or the next vulnerability affects your stack