What’s Vulnerable › Vulnerabilities
CVE-2023-50255: Zip Path Traversal in Deepin-Compressor
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-27 · updated 2026-06-17
- Weakness: CWE-22
Description
Deepin-Compressor is the default archive manager of Deepin Linux OS. Prior to 5.12.21, there's a path traversal vulnerability in deepin-compressor that can be exploited to achieve Remote Command Execution on the target system upon opening crafted archives. Users are advised to update to version 5.12.21 which addresses the issue. There are no known workarounds for this vulnerability.
Affected products
- Deepin-Compressor: before 5.12.21 — fixed in 5.12.21
How to fix
Upgrade to a fixed version: Deepin-Compressor 5.12.21. Check the vendor advisory for mitigations.
References
- https://github.com/linuxdeepin/deepin-compressor/commit/82f668c78c133873f5094cfab6e4eabc0b70e4b6
- https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-rw5r-8p9h-3gp2
- https://github.com/linuxdeepin/deepin-compressor/commit/82f668c78c133873f5094cfab6e4eabc0b70e4b6
- https://github.com/linuxdeepin/developer-center/security/advisories/GHSA-rw5r-8p9h-3gp2
Get alerted when CVE-2023-50255 or the next vulnerability affects your stack