What’s Vulnerable › Vulnerabilities
CVE-2023-50267: MeterSphere horizontal privilege escalation vulnerability of resources in project scope.
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-28 · updated 2026-06-17
- Weakness: CWE-269
Description
MeterSphere is a one-stop open source continuous testing platform. Prior to 2.10.10-lts, the authenticated attackers can update resources which don't belong to him if the resource ID is known. This issue if fixed in 2.10.10-lts. There are no known workarounds.
Affected products
- metersphere: before 2.10.10 — fixed in 2.10.10
How to fix
Upgrade to a fixed version: metersphere 2.10.10. Check the vendor advisory for mitigations.
References
- https://github.com/metersphere/metersphere/security/advisories/GHSA-rcp4-c5p2-58v9
- https://github.com/metersphere/metersphere/security/advisories/GHSA-rcp4-c5p2-58v9
Get alerted when CVE-2023-50267 or the next vulnerability affects your stack