What’s Vulnerable › Vulnerabilities
CVE-2023-50308: IBM Db2 denial of service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-22 · updated 2026-06-17
- Weakness: CWE-20
Description
IBM Db2 for Linux, UNIX and Windows (includes DB2 Connect Server) 11.5 under certain circumstances could allow an authenticated user to the database to cause a denial of service when a statement is run on columnar tables. IBM X-Force ID: 273393.
Affected products
- IBM Db2 for Linux, UNIX and Windows: before 11.5.9 — fixed in 11.5.9
How to fix
Upgrade to a fixed version: IBM Db2 for Linux, UNIX and Windows 11.5.9. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/273393
- https://security.netapp.com/advisory/ntap-20240307-0001/
- https://www.ibm.com/support/pages/node/7105506
- https://exchange.xforce.ibmcloud.com/vulnerabilities/273393
- https://security.netapp.com/advisory/ntap-20240307-0001/
- https://www.ibm.com/support/pages/node/7105506
Get alerted when CVE-2023-50308 or the next vulnerability affects your stack