What’s Vulnerable › Vulnerabilities
CVE-2023-50312: IBM WebSphere Application Server Liberty information disclosure
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-327
Description
IBM WebSphere Application Server Liberty 17.0.0.3 through 24.0.0.2 could provide weaker than expected security for outbound TLS connections caused by a failure to honor user configuration. IBM X-Force ID: 274711.
Affected products
- IBM WebSphere Application Server: from 17.0.0.3 before 24.0.0.3 — fixed in 24.0.0.3
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 24.0.0.3. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/274711
- https://www.ibm.com/support/pages/node/7125527
- https://exchange.xforce.ibmcloud.com/vulnerabilities/274711
- https://www.ibm.com/support/pages/node/7125527
Get alerted when CVE-2023-50312 or the next vulnerability affects your stack