What’s Vulnerable › Vulnerabilities
CVE-2023-50378: Apache Ambari: Various XSS problems
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Lack of proper input validation and constraint enforcement in Apache Ambari prior to 2.7.8 Impact : As it will be stored XSS, Could be exploited to perform unauthorized actions, varying from data access to session hijacking and delivering malicious payloads. Users are recommended to upgrade to version 2.7.8 which fixes this issue.
Affected products
- Apache Software Foundation Apache Ambari: from 2.7.0 before 2.7.8 — fixed in 2.7.8
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ambari 2.7.8. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/6hn0thq743vz9gh283s2d87wz8tqh37c
- http://www.openwall.com/lists/oss-security/2024/03/01/5
- https://lists.apache.org/thread/6hn0thq743vz9gh283s2d87wz8tqh37c
Get alerted when CVE-2023-50378 or the next vulnerability affects your stack