What’s Vulnerable › Vulnerabilities
CVE-2023-50379: Apache Ambari: authenticated users could perform command injection to perform RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-27 · updated 2026-06-17
- Weakness: CWE-94
Description
Malicious code injection in Apache Ambari in prior to 2.7.8. Users are recommended to upgrade to version 2.7.8, which fixes this issue. Impact: A Cluster Operator can manipulate the request by adding a malicious code injection and gain a root over the cluster main host.
Affected products
- Apache Software Foundation Apache Ambari: before 2.7.8 — fixed in 2.7.8
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ambari 2.7.8. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/02/27/1
- https://lists.apache.org/thread/jglww6h6ngxpo1r6r5fx7ff7z29lnvv8
- http://www.openwall.com/lists/oss-security/2024/02/27/1
- https://lists.apache.org/thread/jglww6h6ngxpo1r6r5fx7ff7z29lnvv8
Get alerted when CVE-2023-50379 or the next vulnerability affects your stack