What’s Vulnerable › Vulnerabilities
CVE-2023-50423: Escalation of Privileges in SAP BTP Security Services Integration Library ([Python] cloud-pysec)
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-12 · updated 2026-06-17
- Weakness: CWE-749
Description
SAP BTP Security Services Integration Library ([Python] sap-xssec) - versions < 4.1.0, allow under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application.
Affected products
- SAP_SE sap-xssec: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: SAP_SE sap-xssec 4.1.0. Check the vendor advisory for mitigations.
References
- https://blogs.sap.com/2023/12/12/unveiling-critical-security-updates-sap-btp-security-note-3411067/
- https://github.com/SAP/cloud-pysec/
- https://github.com/SAP/cloud-pysec/security/advisories/GHSA-6mjg-37cp-42x5
- https://me.sap.com/notes/3411067
- https://pypi.org/project/sap-xssec/
- https://www.sap.com/documents/2022/02/fa865ea4-167e-0010-bca6-c68f7e60039b.html
- https://blogs.sap.com/2023/12/12/unveiling-critical-security-updates-sap-btp-security-note-3411067/
- https://github.com/SAP/cloud-pysec/
- https://github.com/SAP/cloud-pysec/security/advisories/GHSA-6mjg-37cp-42x5
- https://me.sap.com/notes/3411067
- https://pypi.org/project/sap-xssec/
- https://www.sap.com/documents/2022/02/fa865ea4-167e-0010-bca6-c68f7e60039b.html
Get alerted when CVE-2023-50423 or the next vulnerability affects your stack