What’s Vulnerable › Vulnerabilities
CVE-2023-5060: Cross-site Scripting (XSS) - DOM in librenms/librenms
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - DOM in GitHub repository librenms/librenms prior to 23.9.1.
Affected products
- librenms: before 23.9.1 — fixed in 23.9.1
How to fix
Upgrade to a fixed version: librenms 23.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/8fd8d9b06a11060de5dc69588a1a83594a7e6f72
- https://huntr.dev/bounties/01b0917d-f92f-4903-9eca-bcfc46e847e3
- https://github.com/librenms/librenms/commit/8fd8d9b06a11060de5dc69588a1a83594a7e6f72
- https://huntr.dev/bounties/01b0917d-f92f-4903-9eca-bcfc46e847e3
Get alerted when CVE-2023-5060 or the next vulnerability affects your stack