What’s Vulnerable › Vulnerabilities

CVE-2023-5061: Missing Authorization in GitLab

Description

An issue has been discovered in GitLab affecting all versions starting from 9.3 before 16.4.4, all versions starting from 16.5 before 16.5.4, all versions starting from 16.6 before 16.6.2. In certain situations, it may have been possible for developers to override predefined CI variables via the REST API.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.4.4, 16.5.4, 16.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-5061 or the next vulnerability affects your stack