What’s Vulnerable › Vulnerabilities
CVE-2023-50721: XWiki Platform RCE from account through SearchAdmin
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 78.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-15 · updated 2026-06-17
- Weakness: CWE-94
Description
XWiki Platform is a generic wiki platform. Starting in 4.5-rc-1 and prior to versions 14.10.15, 15.5.2, and 15.7-rc-1, the search administration interface doesn't properly escape the id and label of search user interface extensions, allowing the injection of XWiki syntax containing script macros including Groovy macros that allow remote code execution, impacting the confidentiality, integrity and availability of the whole XWiki instance. This attack can be executed by any user who can edit some wiki page like the user's profile (editable by default) as user interface extensions that will be displayed in the search administration can be added on any document by any user. The necessary escaping has been added in XWiki 14.10.15, 15.5.2 and 15.7RC1. As a workaround, the patch can be applied manually applied to the page `XWiki.SearchAdmin`.
Affected products
- xwiki-platform: from 4.5 before 14.10.5; from 15.0 before 15.5.2; 15.6, 15.6-rc1, 15.7-rc1 — fixed in 14.10.5, 15.5.2
How to fix
Upgrade to a fixed version: xwiki-platform 14.10.5, 15.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/62863736d78ffd60d822279c5fb7fb9593042766
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-7654-vfh6-rw6x
- https://jira.xwiki.org/browse/XWIKI-21200
- https://github.com/xwiki/xwiki-platform/commit/62863736d78ffd60d822279c5fb7fb9593042766
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-7654-vfh6-rw6x
- https://jira.xwiki.org/browse/XWIKI-21200
Get alerted when CVE-2023-50721 or the next vulnerability affects your stack