What’s Vulnerable › Vulnerabilities
CVE-2023-50724: Resque vulnerable to reflected cross site scripting through pathname
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Resque (pronounced like "rescue") is a Redis-backed library for creating background jobs, placing those jobs on multiple queues, and processing them later. resque-web in resque versions before 2.1.0 are vulnerable to reflected XSS through the current_queue parameter in the path of the queues endpoint. This issue has been patched in version 2.1.0.
Affected products
- resque: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: resque 2.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/resque/resque/issues/1679
- https://github.com/resque/resque/pull/1687
- https://github.com/resque/resque/security/advisories/GHSA-r8xx-8vm8-x6wj
- https://github.com/resque/resque/issues/1679
- https://github.com/resque/resque/pull/1687
- https://github.com/resque/resque/security/advisories/GHSA-r8xx-8vm8-x6wj
Get alerted when CVE-2023-50724 or the next vulnerability affects your stack