What’s Vulnerable › Vulnerabilities
CVE-2023-50725: Resque vulnerable to reflected XSS in resque-web failed and queues lists
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Resque is a Redis-backed Ruby library for creating background jobs, placing them on multiple queues, and processing them later. The following paths in resque-web have been found to be vulnerable to reflected XSS: "/failed/?class=<script>alert(document.cookie)</script>" and "/queues/><img src=a onerror=alert(document.cookie)>". This issue has been patched in version 2.2.1.
Affected products
- resque: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: resque 2.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/resque/resque/commit/ee99d2ed6cc75d9d384483b70c2d96d312115f07
- https://github.com/resque/resque/pull/1790
- https://github.com/resque/resque/security/advisories/GHSA-gc3j-vvwf-4rp8
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/resque/CVE-2023-50725.yml
- https://github.com/resque/resque/commit/ee99d2ed6cc75d9d384483b70c2d96d312115f07
- https://github.com/resque/resque/pull/1790
- https://github.com/resque/resque/security/advisories/GHSA-gc3j-vvwf-4rp8
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/resque/CVE-2023-50725.yml
Get alerted when CVE-2023-50725 or the next vulnerability affects your stack