What’s Vulnerable › Vulnerabilities
CVE-2023-50727: Resque vulnerable to reflected XSS in Queue Endpoint
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Resque is a Redis-backed Ruby library for creating background jobs, placing them on multiple queues, and processing them later. Reflected XSS issue occurs when /queues is appended with /"><svg%20onload=alert(domain)>. This issue has been patched in version 2.6.0.
Affected products
- resque: before 2.6.0 — fixed in 2.6.0
How to fix
Upgrade to a fixed version: resque 2.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/resque/resque/commit/7623b8dfbdd0a07eb04b19fb25b16a8d6f087f9a
- https://github.com/resque/resque/pull/1865
- https://github.com/resque/resque/security/advisories/GHSA-r9mq-m72x-257g
- https://github.com/resque/resque/commit/7623b8dfbdd0a07eb04b19fb25b16a8d6f087f9a
- https://github.com/resque/resque/pull/1865
- https://github.com/resque/resque/security/advisories/GHSA-r9mq-m72x-257g
Get alerted when CVE-2023-50727 or the next vulnerability affects your stack