What’s Vulnerable › Vulnerabilities

CVE-2023-50728: Unauthenticated Denial of Service in the octokit/webhooks library

Description

octokit/webhooks is a GitHub webhook events toolset for Node.js. Starting in 9.26.0 and prior to 9.26.3, 10.9.2, 11.1.2, and 12.0.4, there is a problem caused by an issue with error handling in the @octokit/webhooks library because the error can be undefined in some cases. The resulting request was found to cause an uncaught exception that ends the nodejs process. The bug is fixed in octokit/webhooks.js 9.26.3, 10.9.2, 11.1.2, and 12.0.4, app.js 14.02, octokit.js 3.1.2, and Protobot 12.3.3.

Affected products

How to fix

Upgrade to a fixed version: Octokit 3.1.2; octokit Webhooks 10.9.2, 11.1.2, 12.0.4, 9.26.3; Probot 12.3.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-50728 or the next vulnerability affects your stack