What’s Vulnerable › Vulnerabilities
CVE-2023-50809
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-121
Description
In certain Sonos products before S1 Release 11.12 and S2 release 15.9, the mt_7615.ko wireless driver does not properly validate an information element during negotiation of a WPA2 four-way handshake. This lack of validation leads to a stack buffer overflow. This can result in remote code execution within the kernel. This affects Amp, Arc, Arc SL, Beam, Beam Gen 2, Beam SL, and Five.
Affected products
- Sonos S2: before 15.9 — fixed in 15.9
How to fix
Upgrade to a fixed version: Sonos S2 15.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-50809 or the next vulnerability affects your stack