What’s Vulnerable › Vulnerabilities
CVE-2023-50852: WordPress BookIt Plugin <= 2.4.3 is vulnerable to SQL Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-28 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in StylemixThemes Booking Calendar | Appointment Booking | BookIt.This issue affects Booking Calendar | Appointment Booking | BookIt: from n/a through 2.4.3.
Affected products
- stellarwp Bookit — Booking & Appointment Calendar: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: stellarwp Bookit — Booking & Appointment Calendar 2.4.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/bookit/wordpress-bookit-plugin-2-4-3-sql-injection-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/bookit/wordpress-bookit-plugin-2-4-3-sql-injection-vulnerability?_s_id=cve
Get alerted when CVE-2023-50852 or the next vulnerability affects your stack