What’s Vulnerable › Vulnerabilities
CVE-2023-5087: PageLayer < 1.7.8 - Author+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-16 · updated 2026-06-17
Description
The Page Builder: Pagelayer WordPress plugin before 1.7.8 doesn't prevent attackers with author privileges and higher from inserting malicious JavaScript inside a post's header or footer code.
Affected products
- softaculous Page Builder: Pagelayer – Drag and Drop website builder: before 1.7.8 — fixed in 1.7.8
How to fix
Upgrade to a fixed version: softaculous Page Builder: Pagelayer – Drag and Drop website builder 1.7.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3b45cc0b-7378-49f3-900e-d0e18cd4b878
- https://wpscan.com/vulnerability/3b45cc0b-7378-49f3-900e-d0e18cd4b878
Get alerted when CVE-2023-5087 or the next vulnerability affects your stack