What’s Vulnerable › Vulnerabilities
CVE-2023-50924: Stored XSS in Overview and Output fields
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Englesystem is a shift planning system for chaos events. Engelsystem prior to v3.4.1 performed insufficient validation of user supplied data for the DECT number, mobile number, and work-log comment fields. The values of those fields would be displayed in corresponding log overviews, allowing the injection and execution of Javascript code in another user's context. This vulnerability enables an authenticated user to inject Javascript into other user's sessions. The injected JS will be executed during normal usage of the system when viewing, e.g., overview pages. This issue has been fixed in version 3.4.1.
Affected products
- engelsystem: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: engelsystem 3.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/engelsystem/engelsystem/commit/efda1ffc1ce59f02a7d237d9087adea26e73ec5f
- https://github.com/engelsystem/engelsystem/security/advisories/GHSA-p5ch-rrpm-wvhm
- https://github.com/engelsystem/engelsystem/commit/efda1ffc1ce59f02a7d237d9087adea26e73ec5f
- https://github.com/engelsystem/engelsystem/security/advisories/GHSA-p5ch-rrpm-wvhm
Get alerted when CVE-2023-50924 or the next vulnerability affects your stack