What’s Vulnerable › Vulnerabilities
CVE-2023-50944: Apache Airflow: Bypass permission verification to read code of other dags
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-24 · updated 2026-06-17
- Weakness: CWE-862
Description
Apache Airflow, versions before 2.8.1, have a vulnerability that allows an authenticated user to access the source code of a DAG to which they don't have access. This vulnerability is considered low since it requires an authenticated user to exploit it. Users are recommended to upgrade to version 2.8.1, which fixes this issue.
Affected products
- Apache Airflow: before 2.8.1 — fixed in 2.8.1
How to fix
Upgrade to a fixed version: Apache Airflow 2.8.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/01/24/5
- https://github.com/apache/airflow/pull/36257
- https://lists.apache.org/thread/92krb5mpcq8qrw4t4j5oooqw7hgd8q7h
- http://www.openwall.com/lists/oss-security/2024/01/24/5
- https://github.com/apache/airflow/pull/36257
- https://lists.apache.org/thread/92krb5mpcq8qrw4t4j5oooqw7hgd8q7h
Get alerted when CVE-2023-50944 or the next vulnerability affects your stack