What’s Vulnerable › Vulnerabilities

CVE-2023-5106: Incorrect Authorization in GitLab

Description

An issue has been discovered in Ultimate-licensed GitLab EE affecting all versions starting 13.12 prior to 16.2.8, 16.3.0 prior to 16.3.5, and 16.4.0 prior to 16.4.1 that could allow an attacker to impersonate users in CI pipelines through direct transfer group imports.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.2.8, 16.3.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-5106 or the next vulnerability affects your stack