What’s Vulnerable › Vulnerabilities
CVE-2023-51074
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-27 · updated 2026-06-17
Description
json-path v2.8.0 was discovered to contain a stack overflow via the Criteria.parse() method.
Affected products
- Json-Path Jayway Jsonpath: from 2.2.0 before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: Json-Path Jayway Jsonpath 2.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-51074 or the next vulnerability affects your stack