What’s Vulnerable › Vulnerabilities
CVE-2023-5117: Exposure of Sensitive Information Due to Incompatible Policies in GitLab
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-25 · updated 2026-06-17
- Weakness: CWE-213
Description
An issue was discovered in GitLab CE/EE affecting all versions before 17.6.0 in which users were unaware that files uploaded to comments on confidential issues and epics of public projects could be accessed without authentication via a direct link to the uploaded file URL.
Affected products
- GitLab: before 17.6.0 — fixed in 17.6.0
How to fix
Upgrade to a fixed version: GitLab 17.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-5117 or the next vulnerability affects your stack