What’s Vulnerable › Vulnerabilities
CVE-2023-5124: PageLayer < 1.8.0 - Author+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-01-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Builder: Pagelayer WordPress plugin before 1.8.0 doesn't prevent attackers with administrator privileges from inserting malicious JavaScript inside a post's header or footer code, even when unfiltered_html is disallowed, such as in multi-site WordPress configurations.
Affected products
- softaculous Page Builder: Pagelayer – Drag and Drop website builder: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: softaculous Page Builder: Pagelayer – Drag and Drop website builder 1.8.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1ef86546-3467-432c-a863-1ca3e5c65bd4/
- https://wpscan.com/vulnerability/1ef86546-3467-432c-a863-1ca3e5c65bd4/
Get alerted when CVE-2023-5124 or the next vulnerability affects your stack