What’s Vulnerable › Vulnerabilities
CVE-2023-51359: WordPress Essential Blocks plugin <= 4.2.0 - Multiple Contributor+ Broken Access Control vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-09 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in WPDeveloper Essential Blocks for Gutenberg essential-blocks allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Essential Blocks for Gutenberg: from n/a through <= 4.2.0.
Affected products
- wpdevteam Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns: before 4.2.1 — fixed in 4.2.1
How to fix
Upgrade to a fixed version: wpdevteam Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns 4.2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-51359 or the next vulnerability affects your stack