What’s Vulnerable › Vulnerabilities
CVE-2023-51384
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-18 · updated 2026-10-15
- Weakness: CWE-284
Description
In ssh-agent in OpenSSH before 9.6, certain destination constraints can be incompletely applied. When destination constraints are specified during addition of PKCS#11-hosted private keys, these constraints are only applied to the first key, even if a PKCS#11 token returns multiple keys.
Affected products
- Debian Linux: 11.0, 12.0
- OpenSSH: from 8.9 before 9.6 — fixed in 9.6
How to fix
Upgrade to a fixed version: OpenSSH 9.6. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2024/Mar/21
- https://github.com/openssh/openssh-portable/commit/881d9c6af9da4257c69c327c4e2f1508b2fa754b
- https://security.netapp.com/advisory/ntap-20240105-0005/
- https://support.apple.com/kb/HT214084
- https://www.debian.org/security/2023/dsa-5586
- https://www.openssh.com/txt/release-9.6
- https://www.openwall.com/lists/oss-security/2023/12/18/2
- http://seclists.org/fulldisclosure/2024/Mar/21
- https://github.com/openssh/openssh-portable/commit/881d9c6af9da4257c69c327c4e2f1508b2fa754b
- https://security.netapp.com/advisory/ntap-20240105-0005/
- https://support.apple.com/kb/HT214084
- https://www.debian.org/security/2023/dsa-5586
Get alerted when CVE-2023-51384 or the next vulnerability affects your stack