What’s Vulnerable › Vulnerabilities
CVE-2023-51387: Expression Injection Vulnerability in Hertzbeat
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-22 · updated 2026-06-17
- Weakness: CWE-94
Description
Hertzbeat is an open source, real-time monitoring system. Hertzbeat uses aviatorscript to evaluate alert expressions. The alert expressions are supposed to be some simple expressions. However, due to improper sanitization for alert expressions in version prior to 1.4.1, a malicious user can use a crafted alert expression to execute any command on hertzbeat server. A malicious user who has access to alert define function can execute any command in hertzbeat instance. This issue is fixed in version 1.4.1.
Affected products
- dromara hertzbeat: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: dromara hertzbeat 1.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/dromara/hertzbeat/blob/6b599495763120ad1df6f4ed4b6713bb4885d8e2/home/blog/2023-09-26-hertzbeat-v1.4.1.md
- https://github.com/dromara/hertzbeat/commit/8dcf050e27ca95d15460a7ba98a3df8a9cd1d3d2
- https://github.com/dromara/hertzbeat/security/advisories/GHSA-4576-m8px-w9qj
- https://github.com/dromara/hertzbeat/blob/6b599495763120ad1df6f4ed4b6713bb4885d8e2/home/blog/2023-09-26-hertzbeat-v1.4.1.md
- https://github.com/dromara/hertzbeat/commit/8dcf050e27ca95d15460a7ba98a3df8a9cd1d3d2
- https://github.com/dromara/hertzbeat/security/advisories/GHSA-4576-m8px-w9qj
Get alerted when CVE-2023-51387 or the next vulnerability affects your stack