What’s Vulnerable › Vulnerabilities
CVE-2023-51409: WordPress AI Engine plugin <= 1.9.98 - Unauthenticated Arbitrary File Upload vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 63.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-12 · updated 2026-06-17
- Weakness: CWE-434
Description
Unrestricted Upload of File with Dangerous Type vulnerability in Jordy Meow AI Engine: ChatGPT Chatbot.This issue affects AI Engine: ChatGPT Chatbot: from n/a through 1.9.98.
Affected products
- AI Engine: before 1.9.99 — fixed in 1.9.99
How to fix
Upgrade to a fixed version: AI Engine 1.9.99. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/ai-engine/wordpress-ai-engine-plugin-1-9-98-unauthenticated-arbitrary-file-upload-vulnerability?_s_id=cve
- https://github.com/JoshuaProvoste/0-click-RCE-Exploit-for-CVE-2023-51409
- https://patchstack.com/database/vulnerability/ai-engine/wordpress-ai-engine-plugin-1-9-98-unauthenticated-arbitrary-file-upload-vulnerability?_s_id=cve
Get alerted when CVE-2023-51409 or the next vulnerability affects your stack