What’s Vulnerable › Vulnerabilities
CVE-2023-51437: Apache Pulsar: Timing attack in SASL token signature verification
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-07 · updated 2026-06-17
- Weakness: CWE-203
Description
Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .
Affected products
- Apache Software Foundation Apache Pulsar: through 2.10.5; from 2.11.0 before 2.11.3; from 3.0.0 before 3.0.2; 3.1.0, 3.1.0-candidate_1 — fixed in 2.11.3, 3.0.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Pulsar 2.11.3, 3.0.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5
- https://www.openwall.com/lists/oss-security/2024/02/07/1
- https://lists.apache.org/thread/5kgmvvolf5tzp5rz9xjwfg2ncwvqqgl5
- https://www.openwall.com/lists/oss-security/2024/02/07/1
Get alerted when CVE-2023-51437 or the next vulnerability affects your stack