What’s Vulnerable › Vulnerabilities
CVE-2023-51451: SSRF in symbolicator via invalid protocol
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-22 · updated 2026-06-17
- Weakness: CWE-918
Description
Symbolicator is a service used in Sentry. Starting in Symbolicator version 0.3.3 and prior to version 21.12.1, an attacker could make Symbolicator send GET HTTP requests to arbitrary URLs with internal IP addresses by using an invalid protocol. The responses of those requests could be exposed via Symbolicator's API. In affected Sentry instances, the data could be exposed through the Sentry API and user interface if the attacker has a registered account. The issue has been fixed in Symbolicator release 23.12.1, Sentry self-hosted release 23.12.1, and has already been mitigated on sentry.io on December 18, 2023. If updating is not possible, some other mitigations are available. One may disable JS processing by toggling the option `Allow JavaScript Source Fetching` in `Organization Settings > Security & Privacy` and/or disable all untrusted public repositories under `Project Settings > Debug Files`. Alternatively, if JavaScript and native symbolication are not required, disable Symbolicator completely in `config.yml`.
Affected products
- getsentry symbolicator: from 0.3.3 before 23.12.1 — fixed in 23.12.1
How to fix
Upgrade to a fixed version: getsentry symbolicator 23.12.1. Check the vendor advisory for mitigations.
References
- https://github.com/getsentry/self-hosted/releases/tag/23.12.1
- https://github.com/getsentry/symbolicator/pull/1343
- https://github.com/getsentry/symbolicator/releases/tag/23.12.1
- https://github.com/getsentry/symbolicator/security/advisories/GHSA-ghg9-7m82-h96r
- https://github.com/getsentry/self-hosted/releases/tag/23.12.1
- https://github.com/getsentry/symbolicator/pull/1343
- https://github.com/getsentry/symbolicator/releases/tag/23.12.1
- https://github.com/getsentry/symbolicator/security/advisories/GHSA-ghg9-7m82-h96r
Get alerted when CVE-2023-51451 or the next vulnerability affects your stack