What’s Vulnerable › Vulnerabilities
CVE-2023-51455
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-02 · updated 2026-06-17
- Weakness: CWE-129
Description
A Improper Validation of Array Index issue affecting the v2_sdk_service running on a set of DJI drone devices on the port 10000 could allow an attacker to corrupt a controlled memory location due to a missing input validation in the on_receive_session_packet_ack function implemented in the libv2_sdk.so library used by the dji_vtwo_sdk binary implementing the service, potentially leading to a memory information leak or to an arbitrary code execution. Affected models are Mavic 3 Pro until v01.01.0300, Mavic 3 until v01.00.1200, Mavic 3 Classic until v01.00.0500, Mavic 3 Enterprise until v07.01.10.03, Matrice 300 until v57.00.01.00, Matrice M30 until v07.01.0022 and Mini 3 Pro until v01.00.0620.
Affected products
- DJI Matrice 300 Firmware: before 57.00.01.00 — fixed in 57.00.01.00
- DJI Matrice M30 Firmware: before 07.01.0022 — fixed in 07.01.0022
- DJI Mavic 3 Firmware: before 01.00.1200 — fixed in 01.00.1200
- DJI Mavic 3 Pro Firmware: before 01.01.0300 — fixed in 01.01.0300
- DJI Mini 3 Pro Firmware: before 01.00.0620 — fixed in 01.00.0620
How to fix
Upgrade to a fixed version: DJI Matrice 300 Firmware 57.00.01.00; DJI Matrice M30 Firmware 07.01.0022; DJI Mavic 3 Firmware 01.00.1200; DJI Mavic 3 Pro Firmware 01.01.0300; DJI Mini 3 Pro Firmware 01.00.0620. Check the vendor advisory for mitigations.
References
- https://www.nozominetworks.com/labs/vulnerability-advisories-cve-2023-51455/
- https://www.nozominetworks.com/labs/vulnerability-advisories-cve-2023-51455/
Get alerted when CVE-2023-51455 or the next vulnerability affects your stack