What’s Vulnerable › Vulnerabilities
CVE-2023-51467: Apache OFBiz: Pre-authentication Remote Code Execution (RCE) vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 96.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-26 · updated 2026-06-17
- Weakness: CWE-918
Description
The vulnerability permits attackers to circumvent authentication processes, enabling them to remotely execute arbitrary code
Affected products
- Apache Software Foundation Apache OFBiz: before 18.12.11 — fixed in 18.12.11
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OFBiz 18.12.11. Check the vendor advisory for mitigations.
References
- https://issues.apache.org/jira/browse/OFBIZ-12873
- https://lists.apache.org/thread/9tmf9qyyhgh6m052rhz7lg9vxn390bdv
- https://lists.apache.org/thread/oj2s6objhdq72t6g29omqpcbd1wlp48o
- https://ofbiz.apache.org/download.html
- https://ofbiz.apache.org/release-notes-18.12.11.html
- https://ofbiz.apache.org/security.html
- https://www.openwall.com/lists/oss-security/2023/12/26/3
- https://issues.apache.org/jira/browse/OFBIZ-12873
- https://lists.apache.org/thread/9tmf9qyyhgh6m052rhz7lg9vxn390bdv
- https://lists.apache.org/thread/oj2s6objhdq72t6g29omqpcbd1wlp48o
- https://ofbiz.apache.org/download.html
- https://ofbiz.apache.org/release-notes-18.12.11.html
Get alerted when CVE-2023-51467 or the next vulnerability affects your stack