What’s Vulnerable › Vulnerabilities
CVE-2023-51520: WordPress Booking Calendar Plugin < 9.7.4 is vulnerable to Cross Site Scripting (XSS)
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPdevelop / Oplugins WP Booking Calendar allows Stored XSS.This issue affects WP Booking Calendar: from n/a before 9.7.4.
Affected products
- WPdevelop/Oplugins Booking Calendar (WordPress plugin): before 9.7.4 — fixed in 9.7.4
How to fix
Upgrade to a fixed version: WPdevelop/Oplugins Booking Calendar (WordPress plugin) 9.7.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/booking/wordpress-booking-calendar-plugin-9-7-4-cross-site-scripting-xss-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/booking/wordpress-booking-calendar-plugin-9-7-4-cross-site-scripting-xss-vulnerability?_s_id=cve
Get alerted when CVE-2023-51520 or the next vulnerability affects your stack