What’s Vulnerable › Vulnerabilities
CVE-2023-51543: WordPress RegistrationMagic plugin <= 5.2.5.0 - IP Limit Bypass vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-290
Description
Authentication Bypass by Spoofing vulnerability in Metagauss RegistrationMagic allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects RegistrationMagic: from n/a through 5.2.5.0.
Affected products
- Metagauss RegistrationMagic: before 5.2.5.1 — fixed in 5.2.5.1
How to fix
Upgrade to a fixed version: Metagauss RegistrationMagic 5.2.5.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/custom-registration-form-builder-with-submission-manager/wordpress-registrationmagic-plugin-5-2-5-0-ip-limit-bypass-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/custom-registration-form-builder-with-submission-manager/wordpress-registrationmagic-plugin-5-2-5-0-ip-limit-bypass-vulnerability?_s_id=cve
Get alerted when CVE-2023-51543 or the next vulnerability affects your stack