What’s Vulnerable › Vulnerabilities
CVE-2023-51622: D-Link DIR-X3260 prog.cgi SetTriggerPPPoEValidate Stack-based Buffer Overflow Remote Code Execution Vulnerability
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-121
Description
D-Link DIR-X3260 prog.cgi SetTriggerPPPoEValidate Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of D-Link DIR-X3260 routers. Authentication is required to exploit this vulnerability. The specific flaw exists within the prog.cgi binary, which handles HNAP requests made to the lighttpd webserver listening on TCP ports 80 and 443. The issue results from the lack of proper validation of a user-supplied string before copying it to a fixed-size stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-21672.
Affected products
- D-Link DIR-X3260: before 1.04b01 — fixed in 1.04b01
How to fix
Upgrade to a fixed version: D-Link DIR-X3260 1.04b01. Check the vendor advisory for mitigations.
References
- https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10365
- https://www.zerodayinitiative.com/advisories/ZDI-24-042/
- https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10365
- https://www.zerodayinitiative.com/advisories/ZDI-24-042/
Get alerted when CVE-2023-51622 or the next vulnerability affects your stack