What’s Vulnerable › Vulnerabilities
CVE-2023-51630: Paessler PRTG Network Monitor Cross-Site Scripting Authentication Bypass Vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-02-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Paessler PRTG Network Monitor Cross-Site Scripting Authentication Bypass Vulnerability. This vulnerability allows remote attackers to bypass authentication on affected installations of Paessler PRTG Network Monitor. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the web console. The issue results from the lack of proper validation of user-supplied data, which can lead to the injection of an arbitrary script. An attacker can leverage this vulnerability to bypass authentication on the system. . Was ZDI-CAN-21182.
Affected products
- Paessler PRTG: before 24.1.90.1306 — fixed in 24.1.90.1306
How to fix
Upgrade to a fixed version: Paessler PRTG 24.1.90.1306. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-24-073/
- https://www.zerodayinitiative.com/advisories/ZDI-24-073/
Get alerted when CVE-2023-51630 or the next vulnerability affects your stack