What’s Vulnerable › Vulnerabilities
CVE-2023-51634: NETGEAR RAX30 Improper Certificate Validation Remote Code Execution Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-295
Description
NETGEAR RAX30 Improper Certificate Validation Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to compromise the integrity of downloaded information on affected installations of NETGEAR RAX30 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the downloading of files via HTTPS. The issue results from the lack of proper validation of the certificate presented by the server. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of root. Was ZDI-CAN-19589.
Affected products
- NETGEAR RAX30: before 1.0.12.100_hotfix — fixed in 1.0.12.100_hotfix
How to fix
Upgrade to a fixed version: NETGEAR RAX30 1.0.12.100_hotfix. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065928/Security-Advisory-for-Multiple-Vulnerabilities-on-the-RAX30-PSV-2023-0139
- https://www.zerodayinitiative.com/advisories/ZDI-24-583/
Get alerted when CVE-2023-51634 or the next vulnerability affects your stack