What’s Vulnerable › Vulnerabilities
CVE-2023-51644: Allegra SiteConfigAction Improper Access Control Remote Code Execution Vulnerability
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-22 · updated 2026-06-17
- Weakness: CWE-284
Description
Allegra SiteConfigAction Improper Access Control Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Allegra. Authentication is not required to exploit this vulnerability. The specific flaw exists within the configuration of Struts. The issue results from improper access control. An attacker can leverage this vulnerability to execute code in the context of LOCAL SERVICE. Was ZDI-CAN-22512.
Affected products
- Allegra: before 7.5.1 — fixed in 7.5.1
How to fix
Upgrade to a fixed version: Allegra 7.5.1. Check the vendor advisory for mitigations.
References
- https://www.trackplus.com/en/service/release-notes-reader/7-5-1-release-notes-2.html
- https://www.zerodayinitiative.com/advisories/ZDI-24-102/
Get alerted when CVE-2023-51644 or the next vulnerability affects your stack