What’s Vulnerable › Vulnerabilities
CVE-2023-51697: Audiobookshelf vulnerable to Blind SSRF in `podcastUtils.js`
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-27 · updated 2026-06-17
- Weakness: CWE-918
Description
Audiobookshelf is a self-hosted audiobook and podcast server. Prior to 2.7.0, Audiobookshelf is vulnerable to unauthenticated blind server-side request (SSRF) vulnerability in `podcastUtils.js`. This vulnerability has been addressed in version 2.7.0. There are no known workarounds for this vulnerability.
Affected products
- advplyr audiobookshelf: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: advplyr audiobookshelf 2.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/advplyr/audiobookshelf/commit/f2f2ea161ca0701e1405e737b0df0f96296e4f64
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-jhjx-c3wx-q2x7
- https://github.com/advplyr/audiobookshelf/commit/f2f2ea161ca0701e1405e737b0df0f96296e4f64
- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-jhjx-c3wx-q2x7
Get alerted when CVE-2023-51697 or the next vulnerability affects your stack