What’s Vulnerable › Vulnerabilities
CVE-2023-51713
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-22 · updated 2026-06-17
- Weakness: CWE-125
Description
make_ftp_cmd in main.c in ProFTPD before 1.3.8a has a one-byte out-of-bounds read, and daemon crash, because of mishandling of quote/backslash semantics.
Affected products
- ProFTPD: before 1.3.8a — fixed in 1.3.8a
How to fix
Upgrade to a fixed version: ProFTPD 1.3.8a. Check the vendor advisory for mitigations.
References
- https://github.com/proftpd/proftpd/blob/1.3.8/NEWS
- https://github.com/proftpd/proftpd/issues/1683
- https://github.com/proftpd/proftpd/issues/1683#issuecomment-1712887554
- https://github.com/proftpd/proftpd/blob/1.3.8/NEWS
- https://github.com/proftpd/proftpd/issues/1683
- https://github.com/proftpd/proftpd/issues/1683#issuecomment-1712887554
- https://lists.debian.org/debian-lts-announce/2024/11/msg00032.html
Get alerted when CVE-2023-51713 or the next vulnerability affects your stack